Resources Plugin

Adds a resources post type and simple php calls to display them.

Download here: Resources

Call get_all_resources() on your resources page template (page-resources.php)
<div id=”primary”>
    <div id=”content” role=”main”>
            <?php /* Start the Loop */
            get_all_resources();
    </div><!– #content –>
</div><!– #primary –>

Call get_tax_resources() on your taxonomy page template (taxonomy-restype.php)
eg:
<div id=”primary”>
        <div id=”content” role=”main”>
            <?php /* Start the Loop */
            get_tax_resources();
            ?>
    </div><!– #content –>
</div><!– #primary –>

22 Responses

  1. shutterdude
    shutterdude at | | Reply

    How and where to place this code please …Not very thorough with coding…

    Thanks,
    Arshad

  2. shutterdude
    shutterdude at | | Reply

    Thanks Rob…

    Just one more thing please which location/folder are these files to be placed in?

  3. shutterdude
    shutterdude at | | Reply

    Thanks a lot Rob.

    I am using infinity theme – http://www.proleaner.com
    Have created page-resources.php and taxonomy-restype.php files in theme/infinity.

    Created a blank resources page from dashboard.

    Placed the code in the pages created just like mentioned.

    **************************************************

    <?php /* Start the Loop */
    get_all_resources();

    **************************************************
    Is there something that needs to be there before and after this code on the page (its not working yet)…Please advise

  4. shutterdude
    shutterdude at | | Reply

    As said visited the resources page found it all blank (No Theme)

    Placed the code as below

    <?php /* Start the Loop */
    ‘echo ‘here’;’
    get_all_resources();

    “here didnt show up”
    Trashed the old resource page and created new one

    http://www.proleaner.com/resources-2/

    Page resolves but test post made on resource doesn’t show up nor does “here”

  5. shutterdude
    shutterdude at | | Reply

    Thanks Rob,

    As instructed enabled the slug checkbox in resources-2 page and checked the slug box below, “resources-2″ appears in slug box below as needed…(changed that to “resources” as well to check doesn’t save-didnt work)

    Post made on resources does not resolve in resources page.
    http://www.proleaner.com/resources/unclassified/resource-1/

  6. shutterdude
    shutterdude at | | Reply

    Deleted all the resource pages (including trash) and created new one.

    Then when to permalinks and saved it…

    The Resource page is showing full blank
    http://www.proleaner.com/resources/

    However a post made on resource page is resolving :)
    http://www.proleaner.com/resources/unclassified/resource-1/

    Please advice on Resources page!

  7. shutterdude
    shutterdude at | | Reply

    just to avoid any confusion went to page-resources.php and pasted the code again –

    <?php /* Start the Loop */
    get_all_resources();

    Throws up a blank page as earlier…(visited and saved permalinks as well)
    http://www.proleaner.com/resources/

  8. shutterdude
    shutterdude at | | Reply

    Added the tag

    *******************************

    *******************************
    The page resolves but theme formatting is lost and content of resources pages doesn’t show up.

    http://www.proleaner.com/resources/

    Please excuse my ignorance not able to understand “rest of the template”

    Did you mean index.php by any chance here it is below.

    ***************************************


    ********************************************

    Just in case i didn’t get you right,(which i think i did’nt) kindly clarify and I would gladly share any further information needed.

    Just in case helps pasting the list of files in theme below.
    Theme is infinity – By DesignCoral.com

    ************************************************
    Templates

    404 Template
    (404.php)
    Attachment Template
    (attachment.php)
    Comments
    (comments.php)
    content-attachment.php
    content-page.php
    content-search.php
    content-single.php
    content.php
    custom-header.php
    Footer
    (footer.php)
    Theme Functions
    (functions.php)
    Header
    (header.php)
    Main Index Template
    (index.php)
    init.php
    loop-error.php
    loop-meta.php
    page-resources.php
    Page Template
    (page.php)
    Search Results
    (search.php)
    Search Form
    (searchform.php)
    Sidebar
    (sidebar.php)
    Single Post
    (single.php)
    Blank Template Page Template
    (sq_ddx_blankpage.php)
    taxonomy-restype.php
    **********************************************

    Thanks a lot Rob

  9. shutterdude
    shutterdude at | | Reply

    I think my last post is caught in SPAM Rob …just FYI.

  10. shutterdude
    shutterdude at | | Reply

    Thanks Rob

    On the page-resources.php there is nothing else than what we put (as we created the file)as below…
    ***************************

    ***************************

    Here’s whats in page.php
    ***************************


  11. shutterdude
    shutterdude at | | Reply

    Changed both the pages as instructed…no success.
    Code showing on the page.

    http://www.proleaner.com/resources/

  12. shutterdude
    shutterdude at | | Reply

    Thanks Ron

    The Template is functional now, but still the contents of resources page (which were posted as resource are not visible)

    http://www.proleaner.com/resources/

    However actual posts in resource page resolve successfully.

    http://www.proleaner.com/resources/unclassified/resource-1/

Leave a Reply